Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Senior Member novaracer's Avatar
    Join Date
    Jul 2009
    Location
    ypsilanti MI
    Posts
    378

    mikuni leaking out the overflow

    I got a 22mm mikuni carb kit from nr and i am having some problems with it. i tried the 130 jet for clone but it ran like poop. then i tried the stock jet that i drilled smaller than the 130 and it ran a bit better but then it started leaking out the bottom of the float bowl and the over flow tube/vent. that being said i replaced it with my old bored clone carb and it ran waaayyyy better bottom end and topend. help please!

  2. #2
    125ccCrazy's Avatar
    Join Date
    Dec 2008
    Location
    toledo, ohio
    Posts
    5,255
    check the float to see if it's level when the carb is upside down, also check to see if there is any dirt or debre on the needle/seat.....if those check out it could be the O-ring that goes around the brass seat for the needle, I had a carb where that O-ring shrunk and wouldnt seal allowing fuel to leak past it and into the bowl which over filled and leaked all over..

  3. #3
    Senior Member vette66_00's Avatar
    Join Date
    Apr 2009
    Location
    Fresno, Ca
    Posts
    2,486
    Quote Originally Posted by novaracer View Post
    I got a 22mm mikuni carb kit from nr and i am having some problems with it. i tried the 130 jet for clone but it ran like poop. then i tried the stock jet that i drilled smaller than the 130 and it ran a bit better but then it started leaking out the bottom of the float bowl and the over flow tube/vent. that being said i replaced it with my old bored clone carb and it ran waaayyyy better bottom end and topend. help please!
    You have to tune the carb to your engine. What is your set up. Do you have a pipe? what else?

    When you took off the float bowl did you take out the float assy? If so did you put the float back together right? There is a spring that holds the float to the fuel cut off plunger, if its backward it can bind and cause the bowl to over flow.

    A #130 is a bit rich for most applications I run a #125 with a 17.5 pilot with a cam, rod, flat top piston, springs, billet flywheel, exhaust, and 8 deg advanced.

    These carbs are super sensitive to dirt, you must run a fuel filter to make sure no crud will get into the float and jets.

  4. #4
    Senior Member novaracer's Avatar
    Join Date
    Jul 2009
    Location
    ypsilanti MI
    Posts
    378
    well it has a arc .020 long rod 1.3 rockers cm pushrods the head is ported and has a 3angle valve job shaved .065 26lb springs and a custom ground cam about 260 lift as well as stud kit. i hope i can get this thing to run right with this carb. right now its new to me i had the clone carb down but i knew it was holding it back. because when i went from stock to the bored carb there was a big diff the thing pulled hard.

  5. #5
    Senior Member vette66_00's Avatar
    Join Date
    Apr 2009
    Location
    Fresno, Ca
    Posts
    2,486
    Quote Originally Posted by novaracer View Post
    well it has a arc .020 long rod 1.3 rockers cm pushrods the head is ported and has a 3angle valve job shaved .065 26lb springs and a custom ground cam about 260 lift as well as stud kit. i hope i can get this thing to run right with this carb. right now its new to me i had the clone carb down but i knew it was holding it back. because when i went from stock to the bored carb there was a big diff the thing pulled hard.
    I would get a 125 and a 135 main jet, also a 15 and a 17.5 pilot. To start. This way you can figure out if you are lean or to rich.

  6. #6
    Senior Member novaracer's Avatar
    Join Date
    Jul 2009
    Location
    ypsilanti MI
    Posts
    378
    well looks likei had some dirt in my carb that stuck the float open. it runs ok fo now. but it does seem to idle high but when i crack the throttle open real quick the id;e goes down then comes back up high. like the piolet jet is a bit too small/lean. does that sound right? my plug looks good but i still think the 130 main jet is a bit too small. i have the needle set to the bottom clip point that is where it ran best. any ideas? oh and i added a filter in line also.

  7. #7
    Senior Member JOHN R GANG's Avatar
    Join Date
    Sep 2009
    Location
    East of LA
    Posts
    500
    Quote Originally Posted by novaracer View Post
    well looks likei had some dirt in my carb that stuck the float open. it runs ok fo now. but it does seem to idle high but when i crack the throttle open real quick the id;e goes down then comes back up high. like the piolet jet is a bit too small/lean. does that sound right? my plug looks good but i still think the 130 main jet is a bit too small. i have the needle set to the bottom clip point that is where it ran best. any ideas? oh and i added a filter in line also.
    Still sounds like it has crap in the carb, or pilot jet, or somethings binding. It could be air leak too. Blipping the throttle to restore idle is almost always lean pilot (on a 2 stroke). Is it a chinese Fakuni or a real one? Try cleaning it again and put the needle back to position 3. When I had a Fakuni VM22 on mine I ran 15 pilot, 3rd clip, 140 main and never had the issues you speak of. My clone turned 7888 RPM with that carb.

  8. #8
    Senior Member vette66_00's Avatar
    Join Date
    Apr 2009
    Location
    Fresno, Ca
    Posts
    2,486
    Quote Originally Posted by novaracer View Post
    well looks likei had some dirt in my carb that stuck the float open. it runs ok fo now. but it does seem to idle high but when i crack the throttle open real quick the id;e goes down then comes back up high. like the piolet jet is a bit too small/lean. does that sound right? my plug looks good but i still think the 130 main jet is a bit too small. i have the needle set to the bottom clip point that is where it ran best. any ideas? oh and i added a filter in line also.
    Sounds like the pilot is too lean. Also make sure the throttle slide is retuning to the bottom. If you are at the bottom clip on a #130 jet and it seems lean I would go up 2 sizes. Then re-adjust. 17.5 pilot also. If you are unsure on the main, put a new plug in run it for about 5 mins up and down the block and then check the plug. Black to rich, brown to lean...

  9. #9
    Senior Member novaracer's Avatar
    Join Date
    Jul 2009
    Location
    ypsilanti MI
    Posts
    378
    i will try vett and its a real mikuni

  10. #10
    Senior Member JOHN R GANG's Avatar
    Join Date
    Sep 2009
    Location
    East of LA
    Posts
    500
    Quote Originally Posted by JOHN R GANG View Post
    Still sounds like it has crap in the carb, or pilot jet, or somethings binding. It could be air leak too. Blipping the throttle to restore idle is almost always lean pilot (on a 2 stroke). Is it a chinese Fakuni or a real one? Try cleaning it again and put the needle back to position 3. When I had a Fakuni VM22 on mine I ran 15 pilot, 3rd clip, 140 main and never had the issues you speak of. My clone turned 7888 RPM with that carb.
    Real Mikuni Fake Mikuni

Similar Threads

  1. Leaking Main Jet
    By minimotor in forum Tecumseh Engines
    Replies: 10
    Last Post: 02-04-2014, 06:25 PM
  2. HF Clone leaking down
    By saychz316 in forum Honda / Clone / Predator Engines
    Replies: 1
    Last Post: 09-06-2010, 10:07 AM
  3. Gas overflow on my 4 & 2 1/2hp Techumsehs
    By masterlink in forum Engines and Modifications
    Replies: 2
    Last Post: 07-22-2010, 09:21 PM
  4. oil leaking from governor arm
    By bandit 40 in forum General MiniBike Talk
    Replies: 4
    Last Post: 06-03-2010, 06:26 AM
  5. MB-165 gas tank overflow
    By Kmartrwe in forum General MiniBike Talk
    Replies: 2
    Last Post: 06-21-2009, 02:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •