`
OldMiniBikes.com Home Page Vintage Mini Bike Forum Vintage Mini Bike Pictures
Register Members List Calendar Search Today's Posts Mark Forums Read

Go Back   OldMiniBikes.com Forum > General > Engines and Modifications > Honda / Clone / Predator Engines

Become a Supporting Member of OldMiniBikes.com today and enjoy less advertisements, unlimited photo hosting, and many other benefits listed on this page. Supporting Memberships help pay for bandwidth costs, software upgrades and the time that goes into this site.





Reply
 
Thread Tools Display Modes
Old 10-10-2013, 05:37 PM   #11 (permalink)
Member
 
Join Date: Nov 2011
Location: Chicago
Posts: 38
iTrader: (0)
It still isn't running. I put all of the stock components back on and the factory jet. It will run great at WOT for 10-15 seconds and fall on its face. You can't catch it and bring it back to an idle, it just dies.

Still runs fine with no load at home at all rpms, although it starts hunting at about 3/4 throttle.

I am assuming the small jet under the idle adjustment screw is the idle control circuit? If so I took it completely out and ran it, and blew the jet out with no better results.
Shadowwalker is offline   Reply With Quote
Old 10-10-2013, 06:17 PM   #12 (permalink)
Senior Member
 
Txpowdercoater's Avatar
 
Join Date: Oct 2011
Location: Cut n Shoot, Texas
Posts: 1,426
iTrader: (5)
check fuel supply, make sure you getting fuel to the bowl, then check the needle and seat and make sure its not plugged, partially and moving/operating freely. check the low speed jet, check main jet and emulsion tube and make sure all the holes on the tube are open and not plugged, make sure its clean and then get it running, check plug to see how its running, richen as needed
Txpowdercoater is offline   Reply With Quote
Old 10-10-2013, 08:12 PM   #13 (permalink)
Member
 
Join Date: Nov 2011
Location: Chicago
Posts: 38
iTrader: (0)
figured it out. I was assuming it wasn't getting fuel. I had checked the line and fuel filter back in the spring, even sprayed it with carb cleaner, so of course I thought "I did that already". For the fun of it I took the line off the carb today and was getting a dribble. Took the in tank fuel filter out, tried blowing through it and I was turning red trying. Cut that filter off the barb and ran it. BINGO! Ran like a champ.

Now I am going to just put an inline on it that is easily changed and disposable. I feel like an idiot for not checking it (again) sooner, or trying to blow through it in the spring.

Thanks for everyones help, Now maybe I can put my go fast parts on and get it dialed in.
Shadowwalker is offline   Reply With Quote
Old 10-11-2013, 11:58 AM   #14 (permalink)
Senior Member
 
Boomstick's Avatar
 
Join Date: Oct 2013
Location: Walmart, CT
Posts: 809
iTrader: (0)
Funny how it's just those STUPID little things that give you all sorts of headaches & are more infuriating than the big problems.

For a long time, I couldn't figure out why my little horse n' a half Clinton wouldn't get fuel AT ALL. Like nothing, not a friggin' drop.

Wanna know what it was? Carb needle had this teeny, tiny, barely feelable barb on the nose (the previous Bubba-Jim must have dinged it). Spun it up in a drill with crocus paper, re-installed, and voila. Started second pull.


I make it a practice to remove those dinky in-tank screens. It just prevents headaches.
Boomstick is offline   Reply With Quote
Old 10-13-2013, 06:31 PM   #15 (permalink)
Member
 
Join Date: Nov 2011
Location: Chicago
Posts: 38
iTrader: (0)
Yeah, I really should have put something better on it from the start. Especially since I'm out on the river and can't walk home
Shadowwalker is offline   Reply With Quote
Reply

Lower Navigation
Go Back   OldMiniBikes.com Forum > General > Engines and Modifications > Honda / Clone / Predator Engines

Tags
420cc, loss, predator

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
16 hp power max same as predator 420cc? 93notch408 Honda / Clone / Predator Engines 2 01-10-2013 12:52 PM
13hp Predator (420cc) DoonerFunderburk Honda / Clone / Predator Engines 20 10-07-2012 09:20 PM
420cc Predator budget build JimmyRigged Honda / Clone / Predator Engines 5 07-28-2012 07:17 PM
Predator 420cc 20-25hp iatemeself Honda / Clone / Predator Engines 5 05-02-2012 01:00 AM
predator 420cc how quick proturbo Honda / Clone / Predator Engines 15 08-26-2011 08:51 PM


All times are GMT -4. The time now is 02:00 PM.
Style Developed by Andrew Slane

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2 Copyright 2006-2011 OldMiniBikes.com / OMB Group LLC
Contact Us - OldMiniBikes.com Forum - Archive - Top
no new posts