Register

User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 8 of 8
  1. #1
    Junior Member TDB's Avatar
    Join Date
    Feb 2017
    Location
    Minnesota
    Posts
    24
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Predator 212 keeps dying.

    Any ideas?


    Not sure why this stupid thing won't run, it seems like the fuel line is clogged or the carbs gummed up but I won't know until I tear into it. It ran great last time it was out, and I don't understand why the fuel line would be clogged or the carb gummed up because it didn't sit that long, I only run 91 or 93 non-ethanol, any I always shut the fuel off when I park it. It even started first pull when I pulled it out. Also it's all stock, no mods and it is still governed. Strange.

    *Yes it did have gas in it*

  2. #2
    Senior Member BBQJOE's Avatar
    Join Date
    Jul 2016
    Location
    Arizona
    Posts
    426
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0
    Pull the spark plug, and remove that little piece of carbon caught between the electrodes?

  3. #3
    Junior Member TDB's Avatar
    Join Date
    Feb 2017
    Location
    Minnesota
    Posts
    24
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0
    That was my plan, check the plug first and then go to the carb. Hopefully that's it.

  4. #4
    Senior Member lawn-boy biker's Avatar
    Join Date
    Mar 2009
    Location
    Huntington Station, Long Island, NY
    Posts
    412
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0
    Check gas cap.

  5. #5
    Phil1958's Avatar
    Join Date
    Feb 2013
    Location
    Grass Lake
    Posts
    1,216
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0
    low oil.....
    Giddy Up!

  6. #6
    Junior Member TDB's Avatar
    Join Date
    Feb 2017
    Location
    Minnesota
    Posts
    24
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0
    Good news - I think I fixed it. Bad news - I shot a bunch of gas into my eye. That sucked a lot. Lesson learned to always wear eye protection.

    The spark plug was ok so I pressurized the gas tank and tried to force some crap out of the line, and I also topped off the tank all the way. I haven't ridden it yet but it idled fine so I think I'm good to go.

  7. #7
    Junior Member TDB's Avatar
    Join Date
    Feb 2017
    Location
    Minnesota
    Posts
    24
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0
    Quote Originally Posted by Phil1958 View Post
    low oil.....
    Oil is a little black but there is enough in it.

  8. #8
    Raskin's Avatar
    Join Date
    Jul 2016
    Location
    Florida
    Posts
    1,661
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0
    I would take the gas line off and see if peeing freely before ever taking carb apart..coz sometimes debris get stuck at filter inside tank..they can also move away and run ok ..then get there again..cheers

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •