Help! Predator 212 won't start no matter what I do

#41
Yes, you turn screw left to open and drain
Floatbowl . What I want you to do is use it to check the fuel level in the floatbowl.. you want to tape the clear hose to carb vertically then open drain screw and see how high it rises that will be your fuel level. Does this make sense? Not sure if I am explaining it well.
so im guessing i secure the hose, hold the hose vertically, turn the drain screw and wait for the hose to fill?
 
Last edited:
#42
Correct the fuel in the clear tube will rise to the same height that is in the float bowl. If the fuel level is correct the engine should be able to run for at least 20 seconds.
 
#43
Another test you can do to prove what is going on is:
As Ole has written, when the engine dies to check the fuel level on the carb bowel, pull the spark plug out of the engine. Is it wet or bone dry?
If wet your getting way TOO much fuel.
Pop-corn Phart dry, your starving for fuel.
 
#45
Another test you can do to prove what is going on is:
As Ole has written, when the engine dies to check the fuel level on the carb bowel, pull the spark plug out of the engine. Is it wet or bone dry?
If wet your getting way TOO much fuel.
Pop-corn Phart dry, your starving for fuel.
it is wet, but it would start and die right after i put the enrichener on. it wouldnt start after i turned it off. I also adjusted the needle valve up to the maximum lean setting and it still wont start.
 
#46
You want to go back and open the idle/fuel mixture screw about 1.5 turns out. If you shut it there is no idle mix to run on. The gas being at the top of the bowl says you are getting gravity feed although it should not be that high it does not seem to be your issue. Did you touch the slide height adjuster? We need to understand why it does not continue to run at a fast idle with the enrichener on. It has fuel so not sure what is going on, but it is either too much fuel or not enough. Go back start it with enrichner on, if it dies spray a small shot of starting fluid and see if it restarts, if it does not start after 5 or 6 pulls immediately pull plug and see if it is wet. If it restarts and dies again after the starting fluid (still with the enrichner on) then it sounds like something is wrong with the carb. So to try to get the carb in its normal operating range make sure the idle mix screw is 1.5 to 2 turns out, if you have screwed with the slide adjuster back it off till the slide is all the way down then adjust up so you have about 3/32 of an inch between slide bottom and it bottoming. Re try starting with the enrichment on.
 
#48
If you bought the carb off of the internet it is possible going to the seller or to your home, the carb was "handled" while shipped with some gusto.
ie, it has been thrown around.
It would not take much to bend the float tab or crack a seal on one of the floats. I'd check this first. I've have had this happen more than once over the decades.
http://www.vintagebikebuilder.com/setting-mikuni-float-levels.html

If, when you take off the bowel, the float feels "heavy" for its size, remove the float and shake it. Hear fuel sloshing around? If so the flat(s) are damaged.
 
#49
On the chikuni the floats are hard foam/plastiic and solid. To check float height you turn carb upside down and the float seam should be parallel to the carb base.
 
#50
You want to go back and open the idle/fuel mixture screw about 1.5 turns out. If you shut it there is no idle mix to run on. The gas being at the top of the bowl says you are getting gravity feed although it should not be that high it does not seem to be your issue. Did you touch the slide height adjuster? We need to understand why it does not continue to run at a fast idle with the enrichener on. It has fuel so not sure what is going on, but it is either too much fuel or not enough. Go back start it with enrichner on, if it dies spray a small shot of starting fluid and see if it restarts, if it does not start after 5 or 6 pulls immediately pull plug and see if it is wet. If it restarts and dies again after the starting fluid (still with the enrichner on) then it sounds like something is wrong with the carb. So to try to get the carb in its normal operating range make sure the idle mix screw is 1.5 to 2 turns out, if you have screwed with the slide adjuster back it off till the slide is all the way down then adjust up so you have about 3/32 of an inch between slide bottom and it bottoming. Re try starting with the enrichment on.
so do i bottom the screw out and back it out to 1.5 turns? what does closing the screw do in relation to the fuel mix?
the plunger adjustment clip, is that what you are talking about? i set that to the second to the top notch.
 
#51
No I am talking about the bottom adjustment screw, look at the bottom of the picture, that is the screw. The mixture for idle is set by a fixed air jet and the pilot jet. The screw allows more or less of the mixture into the engine. It has to be adjusted in conjunction with the slide height to get the proper idle. When you change slide height you need to go back and re adjust the idle mix screw.
 

Attachments

#52
No I am talking about the bottom adjustment screw, look at the bottom of the picture, that is the screw. The mixture for idle is set by a fixed air jet and the pilot jet. The screw allows more or less of the mixture into the engine. It has to be adjusted in conjunction with the slide height to get the proper idle. When you change slide height you need to go back and re adjust the idle mix screw.
i think i messed with that screw before coming on here, idk how far it is backed out
 
#60
You need to verify that the slide is positioned correctly for it to idle and so the idle mixture screw will operate as it should. look at this link it shows some of the basics but not the slide height. you need to verify that when the throttle is closed that there is a bit of cable slack so the carb slide is all the way down. Mikuni Carburetor Tuning – Affordable Go Karts I have to go out but I will see if there are any good videos for you to watch. I looked on youtube but the ones I saw were not good. You need to understand the 4 stages of tuning for this carb. Right now we are just trying to get the 1 stage working which is the idle with throttle closed and running on the enrichment on setting. The problem is GPS had their hands on it then you got it and it did not work and you adjusted stuff some more so we need to start from ground zero. You have verified the engine starts on starting fluid so other than a air leak it sure looks like the carb is the issue. Keep in mind we are not there with you so we have to go with the test results you provide.
 
Top