Register

User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Oct 2006
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Question 1970 ssscat I MINNI BIKE

    I just bought a 1970 ssscat I for my little brother. I just got it running! Problem is second gear barely moves the bike, first gear is fine. I was wondering if maybe it's just low on tranny fluid. If so, what type and how much should I add?

    Thanks!

  2. #2
    Senior Member I90Roadking's Avatar
    Join Date
    Jun 2006
    Location
    Bingham Lake, Minnesota
    Posts
    184
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0
    I will have an answer for you tonight.

  3. #3
    Senior Member I90Roadking's Avatar
    Join Date
    Jun 2006
    Location
    Bingham Lake, Minnesota
    Posts
    184
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Tranny fluid

    Use 250 ML of Dexron II ATF. should be 8.4 to 8.8 oz

  4. #4
    . Hent's Avatar
    Join Date
    May 2006
    Location
    South Eastern, PA
    Posts
    4,718
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    Rides
    1
    http://oldminibikes.com/mini/1970-ar...ini-bike-specs

    This may be of interest to you as well. Maybe not.

  5. #5
    Senior Member I90Roadking's Avatar
    Join Date
    Jun 2006
    Location
    Bingham Lake, Minnesota
    Posts
    184
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0
    Hent
    Maybe should post that in the spec page of the bikes with the sachs. Just a thought.

  6. #6
    . Hent's Avatar
    Join Date
    May 2006
    Location
    South Eastern, PA
    Posts
    4,718
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    Rides
    1
    I90,

    When I finish the new version of the mainpage -- it will be much better and more user-friendly, I do believe you saw a glimpse of it so far :)

  7. #7
    Senior Member I90Roadking's Avatar
    Join Date
    Jun 2006
    Location
    Bingham Lake, Minnesota
    Posts
    184
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0
    Yes I did and anxious to see it up and running. When you get it up and running, I have more data to fill in some of the holes in the AC page.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •